[FIXED] Getting "package android.support.multidex does not exist" after upgrading to Android Studio 2.3

Issue

I updated from Android Studio 2.2.3 to Android Studio 2.3 yesterday, and I ran into the following two problems:

  • Upon updating, Gradle 3.2 was installed by default, but syncing my
    project would not work and I kept getting an error saying “Gradle 3.3
    is required”. Using the default Gradle wrapper doesn’t work. The only way to fix this was to download Gradle 3.3
    manually and point to the directory in build settings.

  • On running my project, I kept getting a string of errors involving my
    BaseApplication class which extends MultiDexApplication. The
    error goes something like this:

    Error:(19, 62) error: package android.support.multidex does not exist

I am unable to resolve this error. I have buildToolsVersion '25.0.2', and my project compiled and ran properly before upgrading to Android Studio 2.3. Can anyone help me with this problem?

Solution

The solution to this problem is to add the following:

dependencies {
  implementation 'com.android.support:multidex:1.0.3'
}

in your build.gradle file.

This was not required prior to Gradle 3.3. This problem occurs only for apps that support Android versions below Lollipop (API level 21).

References:

1. Multidex support prior to Android 5.0.

Answered By – Yash Sampat

Answer Checked By – Mary Flores (Easybugfix Volunteer)

Leave a Reply

(*) Required, Your email will not be published