[FIXED] Can't upload ipa to Testflight: Invalid Bundle

Issue

I have a Flutter app and I need to publish a new release.
The upload used to work with no issues with the previous version of Flutter sdk.

To upload the ipa I run:

xcrun altool --upload-app --type ios -f ./path_to_my.ipa --apiKey *** --apiIssuer ***

This is the response

*** Error: Error uploading 'path_to_my.ipa'.
*** Error: Invalid Bundle. The bundle Runner.app/Frameworks/App.framework does not support the minimum OS Version specified in the Info.plist. With error code STATE_ERROR.VALIDATION_ERROR.90208 for id ... Asset validation failed (-19208)
 {
    NSLocalizedDescription = "Invalid Bundle. The bundle Runner.app/Frameworks/App.framework does not support the minimum OS Version specified in the Info.plist. With error code STATE_ERROR.VALIDATION_ERROR.90208 for id ...";
    NSLocalizedFailureReason = "Asset validation failed";
}

This is my env

- Flutter (Channel stable, 3.3.0, on macOS 12.2.1 21D62 darwin-x64, locale it-IT)
- Android toolchain - develop for Android devices (Android SDK version 30.0.3)
- Xcode - develop for iOS and macOS (Xcode 13.2.1)
- Android Studio (version 2021.2)

I already tried setting the minimum deployment target to 10.0 everywhere:

  • Runner -> Runner -> General -> Deployment info: Target
  • Runner -> Runner -> info.plist
  • Runner -> Flutter -> AppFrameworkInfo.plist

Any suggestion?

Solution

As per flutter doc, Flutter has enforced the minimum plugin version of 11 in flutter version 3.3

For more, read Flutter 3.3. Release notes

Answered By – Suz Zan

Answer Checked By – Marilyn (Easybugfix Volunteer)

Leave a Reply

(*) Required, Your email will not be published